CVE-2024-58383: froxlor · Incorrect Permissions
Affects froxlorSource GCVE Database
Not known to be exploited · CVSS 8.4 High : upgrade to 2.2.0-rc4 soon.
Data as of 28 Oct 2026, 00:12 UTC
- Patch
- Available – fixed in 2.2.0-rc4
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade froxlor/froxlor to 2.2.0-rc4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubfroxlor/froxlorpkg:github/froxlor/froxlorOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should verify if an official fix has been released by the Froxlor project. Until then, restrict local code execution capabilities for unprivileged users and consider adjusting file permissions and directory access to prevent unauthorized reading of /etc/pure-ftpd/db/mysql.conf. Monitoring vendor advisories for updates is recommended.
Description
CVE-2024-58383 is a vulnerability in Froxlor versions up to and including 2.2.0-rc3 where the file /etc/pure-ftpd/db/mysql.conf is created with insecure permissions (0644). This file contains the Froxlor SQL user's password, allowing any unprivileged local user with code execution capabilities to read it. Exploiting this, an attacker can access the database, modify administrator credentials, and escalate privileges to root. Only Froxlor instances configured to use pure-ftpd are affected.