Skip to main content
VulnerabilityPublished Updated

CVE-2024-5987: WP Accessibility Helper (WAH) · Missing Authorization

Affects WP Accessibility Helper (WAH)Source CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 0.6.2.8 : update WP Accessibility Helper (WAH) when convenient.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.2.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
vol4ikman WP Accessibility Helper (WAH)Affected
  • =0
Fixed in–

AI-suggested

A patch addressing this vulnerability was released in version 0.6.2.8; however, it reportedly breaks functionality and the vendor has not provided further updates. Users should evaluate the impact of applying the patch in their environment. Until a stable fix is available, consider restricting Subscriber-level access or higher to trusted users only.

Description

The WP Accessibility Helper (WAH) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_contrast_variations' and 'save_empty_contrast_variations' functions in all versions up to, and including, 0.6.2.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to edit or delete contrast settings. Please note these issues were patched in 0.6.2.8, though it broke functionality and the vendor has not responded to our follow-ups.

References

Community reviews

Loading reviews…