CVE-2024-6328: MStore API (WordPress plugin) · Authentication Bypass Using an Alternate Path or Channel
Affects MStore API (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 9.8 Critical · patch available : patch MStore API (WordPress plugin) as a priority.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| inspireui MStore API – Create Native Android & iOS Apps On The Cloud | Affected
| Fixed in– |
AI-suggested
A patch is available for this vulnerability. Users of the MStore API plugin should apply the official update to version 4.14.8 or later as soon as possible to remediate the authentication bypass issue. Until patched, restricting access to the plugin's login endpoints and monitoring for suspicious activity may help reduce risk, but patching is the definitive mitigation.
Description
The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 4.14.7. This is due to insufficient verification on the 'phone' parameter of the 'firebase_sms_login' and 'firebase_sms_login_v2' functions. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email address or phone number. Additionally, if a new email address is supplied, a new user account is created with the default role, even if registration is disabled.
References
- wordfence.com/threat-intel/vulnerabilities/id/17d8e2e9-5e3f-433b-be1a-6ea765eba547?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3115231/ (opens in a new tab)