CVE-2024-6482: OTP Login With Phone Number, OTP Verification (WordPress plugin) · Improper Privilege Management
Affects OTP Login With Phone Number, OTP Verification (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 1.7.40 : patch OTP Login With Phone Number, OTP Verification (WordPress plugin) soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.40
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| glboy OTP Login With Phone Number, OTP Verification | Affected
| Fixed in– |
AI-suggested
The vendor partially addressed the issue in version 1.7.40, but versions 1.7.40 through 1.7.49 remain vulnerable if the pro plugin is installed. Users should upgrade to a version later than 1.7.49 once available or consult the vendor advisory for updated remediation guidance.
Description
The Login with phone number plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.7.49. This is due to a lack of validation and missing capability check on user-supplied data in the 'lwp_update_password_action' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update their role to any other role, including Administrator. The vulnerability was partially patched in version 1.7.40. The login with phone number pro plugin was required to exploit the vulnerability in versions 1.7.40 - 1.7.49.