Skip to main content
VulnerabilityPublished Updated

CVE-2024-6877: Eliz Software Panel · XSS or 'Cross-site Scripting'

Affects Eliz Software PanelSource CVE Database V5

0

Not known to be exploited · CVSS 9.4 Critical : upgrade to 2.3.24 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.24
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Eliz Software Panel to 2.3.24.

Affected software

ProductAffectedFixed in
Eliz Software PanelAffected
  • <2.3.24
Fixed in
  • 2.3.24

AI-suggested

If you cannot patch yet, consider applying temporary mitigations such as input validation and output encoding where feasible, but these should be guided by vendor recommendations.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Eliz Software Panel allows Reflected XSS. This issue affects Panel: before v2.3.24.

References

Community reviews

Loading reviews…