CVE-2024-7476: lunary-ai/lunary · Insecure Direct Object Reference
Affects lunary-ai/lunarySource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium · fixed in 1.4.3 : update lunary-ai/lunary when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-7476, European organizations should immediately upgrade lunary-ai/lunary to version 1.4.3 or later, where the access control flaw is fixed. Until the upgrade is applied, organizations should implement strict monitoring of API endpoints, especially /v1/templates/{id}/versions, to detect anomalous modification attempts. Enforce the principle of least privilege by limiting user permissions to only those necessary for their roles, reducing the risk posed by compromised accounts. Employ multi-factor authentication (MFA) to protect user credentials and reduce the likelihood of unauthorized access. Conduct regular audits of template changes and maintain version control to quickly identify and revert unauthorized modifications. Additionally, implement network segmentation and API gateway controls to restrict access to the lunary-ai/lunary service. Security teams should also educate users about the risks of credential compromise and monitor for suspicious activity related to template management.
Description
A broken access control vulnerability exists in lunary-ai/lunary versions 1.2.7 through 1.4.2. The vulnerability allows an authenticated attacker to modify any user's templates by sending a crafted HTTP POST request to the /v1/templates/{id}/versions endpoint. This issue is resolved in version 1.4.3.