Skip to main content
CVE-2024-7628VulnerabilityPublished Updated

CVE-2024-7628: MStore API (WordPress plugin) · Authentication Bypass Using an Alternate Path or Channel

Affects MStore API (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.1 High · patch available : patch MStore API (WordPress plugin) soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
inspireui MStore API – Create Native Android & iOS Apps On The CloudAffected
  • =0
Fixed in–

AI-suggested

A patch is available for this vulnerability and should be applied promptly to affected versions of the MStore API plugin. Site administrators should update the plugin to a fixed version beyond 4.15.2. No additional mitigations are specified in the advisory. Patch status is confirmed by the 'patchAvailable' field.

Description

The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 4.15.2. This is due to the use of loose comparison in the 'verify_id_token' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to an @flutter.io email address or phone number. This also requires firebase to be configured on the website and the user to have set up firebase for their account.

References

Community reviews

Loading reviews…