Skip to main content
VulnerabilityPublished Updated

CVE-2024-8433: Easy Mega Menu for WordPress – ThemeHunk · Cross-site Scripting

Affects Easy Mega Menu for WordPress – ThemeHunkSource CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · fixed in 1.1.0 : update Easy Mega Menu for WordPress – ThemeHunk when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
themehunk Easy Mega Menu for WordPress – ThemeHunkAffected
  • =0
Fixed in–

AI-suggested

In the meantime, restrict plugin usage to trusted users only and consider disabling or removing the plugin if possible. The partial fix in version 1.1.0 added authorization protection but does not fully resolve the sanitization issue, so upgrading to 1.1.0 may reduce risk but does not eliminate it.

Description

The Easy Mega Menu Plugin for WordPress – ThemeHunk plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘themehunk_megamenu_bg_image' parameter in all versions up to, and including, 1.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Please note that this was partially fixed in 1.1.0 due to the missing authorization protection that was added.

References

Community reviews

Loading reviews…