CVE-2024-9047: Iptanus File Upload (WordPress plugin) · Path Traversal
Affects Iptanus File Upload (WordPress plugin)Source CVE Database V5
Not known to be exploited · public detection template (Nuclei) · 93% EPSS · CVSS 9.8 Critical.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 93.3% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2024
Detectable: evidence found.
nuclei template: WordPress File Upload <= 4.24.11 - Arbitrary File Read
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nickboss Iptanus File Upload | Affected
| Fixed in– |
AI-suggested
Until an official fix is released, it is recommended to upgrade PHP to a version later than 7.4 if possible, or disable the vulnerable plugin. Monitor vendor channels for updates and apply patches promptly once available.
Description
The WordPress File Upload plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 4.24.11 via wfu_file_downloader.php. This makes it possible for unauthenticated attackers to read or delete files outside of the originally intended directory. Successful exploitation requires the targeted WordPress installation to be using PHP 7.4 or earlier.