CVE-2025-0755: MongoDB libbson · Heap-based Buffer Overflow
Affects MongoDB libbsonSource GCVE Database
Not known to be exploited · CVSS 8.4 High · fixed in 8.0.1 : patch MongoDB libbson soon.
Data as of 30 Oct 2026, 00:08 UTC
Thin evidence
One scorer or none| CNA (mongodb) | CVSS 3.1 | 8.4 |
|---|
- Patch
- Available – fixed in 8.0.1, 7.0.16, 1.27.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade MongoDB libbson to 8.0.1, 7.0.16 or 1.27.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDB Inc libbson | Affected
| Fixed in
|
AI-suggested
A fix is available in libbson version 1.27.5, MongoDB Server v8.0.1, and MongoDB Server v7.0.16. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation guidance is provided in the input data.
Description
CVE-2025-0755 is a heap-based buffer overflow vulnerability in the MongoDB C driver library libbson. The issue arises in various bson_append functions when operations produce a BSON document exceeding the maximum size limit (INT32_MAX). This can cause a segmentation fault and potentially crash the application. The vulnerability affects libbson versions prior to 1.27.5, MongoDB Server v8.0 versions prior to 8.0.1, and MongoDB Server v7.0 versions prior to 7.0.16.