Skip to main content
VulnerabilityPublished Updated

CVE-2025-1026: spatie/browsershot · Improper Input Validation

Affects spatie/browsershotSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Public exploit available · CVSS 7.7 High : upgrade to 5.0.5 as a priority.

Data as of 2 Nov 2026, 22:57 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade spatie/browsershot to 5.0.5.

Affected software

ProductAffectedFixed in
Packagistspatie/browsershotpkg:composer/spatie/browsershotOther threatsAffected
  • <5.0.5
Fixed in
  • 5.0.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Versions of the package spatie/browsershot before 5.0.5 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method, which results in a Local File Inclusion allowing the attacker to read sensitive files. **Note:** This is a bypass of the fix for [CVE-2024-21549](https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8533023).

References

Community reviews

Loading reviews…