CVE-2024-21549: spatie/browsershot · Improper Input Validation
Affects spatie/browsershotSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.7 High : upgrade to 5.0.3 soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 20 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade spatie/browsershot to 5.0.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| spatie/browsershot | Affected
| Fixed in
|
AI-suggested
A fix is available in spatie/browsershot version 5.0.3 and later. Users should upgrade to version 5.0.3 or newer to remediate this vulnerability. Patch status is not explicitly stated in the input but the description implies versions before 5.0.3 are vulnerable, so upgrading to 5.0.3 or later is recommended.
Description
Versions of the package spatie/browsershot before 5.0.3 are vulnerable to Improper Input Validation due to improper URL validation in the setUrl method. An attacker can exploit this vulnerability by utilizing view-source:file://, which allows for arbitrary file reading on a local file. **Note:** This is a bypass of the fix for [CVE-2024-21544](https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8496745).