Skip to main content
VulnerabilityPublished

CVE-2025-10503: WSO2 Identity Server · Cross-site Scripting

Affects WSO2 Identity ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 7.1.0.28 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.0.28
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade WSO2 Identity Server to 7.1.0.28.

Affected software

ProductAffectedFixed in
WSO2WSO2 Identity ServerAffected
  • >=7.1.0 <7.1.0.28
Fixed in
  • 7.1.0.28
Mavenorg.wso2.identity/wso2-identity-serverpkg:maven/org.wso2.identity/wso2-identity-serverOther threatsAffected
  • =7.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider applying any recommended temporary mitigations from WSO2 or restrict access to the affected authentication endpoint.

Description

The authentication endpoint accepts user-supplied input without enforcing expected validation constraints, leading to a lack of proper output encoding. This allows for the injection of malicious JavaScript payloads, enabling reflected cross-site scripting. An attacker can leverage this vulnerability to redirect the user's browser to a malicious website, modify the user interface of the web page, retrieve information from the browser, or cause other harmful actions. However, due to the protection of session-related cookies with the httpOnly flag, session hijacking is not possible.

References

Community reviews

Loading reviews…