Skip to main content
VulnerabilityPublished

CVE-2025-10908: WSO2 Identity Server · Incorrect Authorization

Affects WSO2 Identity ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High · fixed in 7.1.0.31 : patch WSO2 Identity Server soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.0.31, 7.0.0.124, 6.1.0.248 +5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade WSO2 to 7.1.0.31, 7.0.0.124, 6.1.0.248 or 6.0.0.249 (Identity Server); 1.1.31.2, 1.1.22.5, 1.1.5.2 or 1.1.0.1 (Carbon MagicLink Authenticator Module).

Affected software

ProductAffectedFixed in
WSO2WSO2 Identity ServerAffected
  • >=7.1.0 <7.1.0.31
Fixed in
  • 7.1.0.31
WSO2WSO2 Identity ServerAffected
  • >=7.0.0 <7.0.0.124
Fixed in
  • 7.0.0.124
WSO2WSO2 Identity ServerAffected
  • >=6.1.0 <6.1.0.248
Fixed in
  • 6.1.0.248
WSO2WSO2 Identity ServerAffected
  • >=6.0.0 <6.0.0.249
Fixed in
  • 6.0.0.249
WSO2WSO2 Carbon MagicLink Authenticator ModuleAffected
  • >=1.1.31 <1.1.31.2
Fixed in
  • 1.1.31.2
WSO2WSO2 Carbon MagicLink Authenticator ModuleAffected
  • >=1.1.22 <1.1.22.5
Fixed in
  • 1.1.22.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2025-10908 is a high-severity vulnerability in WSO2 Identity Server versions 6.0.0, 6.1.0, 7.0.0, and 7.1.0. It arises from a lack of user account state validation during authentication, allowing locked user accounts to be authenticated via Magic Link or Pass Key methods.

References

Community reviews

Loading reviews…