CVE-2025-1094: PostgreSQL · Improper Neutralization of Quoting Syntax
Affects PostgreSQLSource CVE Database V5
Public exploit available (Metasploit) · 90% EPSS · CVSS 8.1 High · fixed in 17.3 : patch PostgreSQL as a priority.
Data as of 3 Nov 2026, 22:57 UTC
Thin evidence
One scorer or none| CNA (PostgreSQL) | CVSS 3.1 | 8.1 |
|---|
- EPSS
- 90.0% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2025-10-16.
- Patch
- Available – fixed in 17.3, 16.7, 15.11 +2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
| PostgreSQL | Affected
| Fixed in
|
AI-suggested
Upgrade PostgreSQL to versions 17.3, 16.7, 15.11, 14.16, or 13.19 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Applying these official fixes fully addresses the issue.
Description
CVE-2025-1094 is a high-severity SQL injection vulnerability in PostgreSQL affecting multiple versions prior to 17.3, 16.7, 15.11, 14.16, and 13.19. It arises from improper neutralization of quoting syntax in libpq functions and command line utilities under certain encoding conditions. Exploitation requires specific usage patterns involving the PostgreSQL interactive terminal (psql) and particular client and server encodings. Public exploit code is available via Metasploit.
References
- postgresql.org/support/security/CVE-2025-1094/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/02/msg00015.html (opens in a new tab)
- openwall.com/lists/oss-security/2025/02/16/3 (opens in a new tab)
- openwall.com/lists/oss-security/2025/02/20/1 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/02/msg00024.html (opens in a new tab)
- security.netapp.com/advisory/ntap-20250221-0010/ (opens in a new tab)