Skip to main content
VulnerabilityPublished

CVE-2025-11850: WSO2 Identity Server · Insecure Direct Object Reference

Affects WSO2 Identity ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 7.1.0.40 or 7.0.0.132 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.0.40, 7.0.0.132
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade WSO2 Identity Server to 7.1.0.40 or 7.0.0.132.

Affected software

ProductAffectedFixed in
WSO2WSO2 Identity ServerAffected
  • >=7.1.0 <7.1.0.40
Fixed in
  • 7.1.0.40
WSO2WSO2 Identity ServerAffected
  • >=7.0.0 <7.0.0.132
Fixed in
  • 7.0.0.132
Mavenorg.wso2.identityserver/wso2-ispkg:maven/org.wso2.identityserver/wso2-isOther threatsAffected
  • =7.0.0
  • =7.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

In the meantime, deployments can mitigate risk by disabling implicit association, ensuring claim values are globally unique across user stores, or avoiding configuration of secondary user stores. Monitor vendor communications for official fixes or updates.

Description

CVE-2025-11850 is a medium severity vulnerability in WSO2 Identity Server versions 7.0.0 and 7.1.0. It occurs when secondary user stores are configured, causing the implicit-association resolver to incorrectly initialize from a secondary user store and bypass the primary user store during search and uniqueness checks. This can lead to identity confusion and incorrect implicit associations when using an external Identity Provider (IDP), potentially restricting legitimate user access if the secondary account has fewer privileges. Deployments without secondary user stores, with implicit association disabled, or with globally unique claim values are not affected.

References

Community reviews

Loading reviews…