Skip to main content
VulnerabilityPublished

CVE-2025-11969: WSO2 Identity Server as Key Manager · Improper Authorization

Affects WSO2 Identity Server as Key ManagerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 5.10.0.367 as a priority.

Data as of 2 Nov 2026, 06:14 UTC

CVSS 3.1 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (WSO2)CVSS 3.19.4
Patch
Available – fixed in 4.5.0.32, 4.4.0.49, 4.3.0.85 +29
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.5.0 <4.5.0.32
Fixed in
  • 4.5.0.32
WSO2WSO2 API ManagerAffected
  • >=4.4.0 <4.4.0.49
Fixed in
  • 4.4.0.49
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.85
Fixed in
  • 4.3.0.85
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.173
Fixed in
  • 4.2.0.173
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.233
Fixed in
  • 4.1.0.233
WSO2WSO2 API ManagerAffected
  • >=4.0.0 <4.0.0.370
Fixed in
  • 4.0.0.370

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in versions 3.1.0.347, 3.2.0.450, 3.2.1.70, 4.0.0.370, 4.1.0.233, 4.2.0.173, 4.3.0.85, 4.4.0.49, 4.5.0.32, and 5.10.0.367. Users should upgrade to one of these fixed versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2025-11969 is an improper authorization vulnerability in WSO2 Identity Server as Key Manager. The System REST APIs fail to enforce correct access control, allowing users with lower privilege roles to perform unauthorized administrative actions. This vulnerability does not affect APIs exposed through the WSO2 API Manager's API Gateway. The issue has been fixed in multiple versions starting from 3.1.0.347 and later.

References

Community reviews

Loading reviews…