Skip to main content
VulnerabilityPublished

CVE-2025-12627: WSO2 Identity Server · Insufficient Session Expiration

Affects WSO2 Identity ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.4 Low : upgrade to 7.1.0.38 or 7.0.0.130 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
2.4Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.0.38, 7.0.0.130, 7.0.259.31 +1
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade WSO2 to 7.1.0.38 or 7.0.0.130 (Identity Server); 7.0.259.31 or 7.0.26.83 (Carbon OAuth).

Affected software

ProductAffectedFixed in
WSO2WSO2 Identity ServerAffected
  • >=7.1.0 <7.1.0.38
Fixed in
  • 7.1.0.38
WSO2WSO2 Identity ServerAffected
  • >=7.0.0 <7.0.0.130
Fixed in
  • 7.0.0.130
WSO2WSO2 Carbon OAuthAffected
  • >=7.0.259 <7.0.259.31
Fixed in
  • 7.0.259.31
WSO2WSO2 Carbon OAuthAffected
  • >=7.0.26 <7.0.26.83
Fixed in
  • 7.0.26.83
Mavenorg.wso2.identity.server/wso2-identity-serverpkg:maven/org.wso2.identity.server/wso2-identity-serverOther threatsAffected
  • =7.0.0
  • =7.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2025-12627 is a vulnerability in WSO2 Identity Server versions 7.0.0 and 7.1.0 where the user impersonation flow does not properly expire refresh tokens. This allows an attacker with an access token for an impersonated user to use the refresh token to obtain new access tokens, extending unauthorized access. The flaw compromises log integrity and traceability by masking the true actor. The CVSS score is low, reflecting limited impact on confidentiality and availability but some impact on integrity.

References

Community reviews

Loading reviews…