Skip to main content
CVE-2025-12967VulnerabilityPublished Updated

CVE-2025-12967: AWS JDBC Wrapper · Unsafe Reflection

Affects AWS JDBC WrapperSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 2.6.5 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.5, 2025-10-17, 2.0.1 +2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Mavencom.amazonaws/aws-advanced-jdbc-wrapperpkg:maven/com.amazonaws/aws-advanced-jdbc-wrapperOther threatsAffected
  • <2.6.5
Fixed in
  • 2.6.5
Gogithub.com/aws/aws-advanced-go-wrapperpkg:golang/github.com/aws/aws-advanced-go-wrapperOther threatsAffected
  • <2025-10-17
Fixed in
  • 2025-10-17
npmaws-advanced-nodejs-wrapperpkg:npm/aws-advanced-nodejs-wrapperOther threatsAffected
  • <2.0.1
Fixed in
  • 2.0.1
PyPIaws-advanced-python-wrapperpkg:pypi/aws-advanced-python-wrapperOther threatsAffected
  • <1.4.0
Fixed in
  • 1.4.0
Mavencom.amazonaws/aws-pgsql-odbcpkg:maven/com.amazonaws/aws-pgsql-odbcOther threatsAffected
  • <1.0.1
Fixed in
  • 1.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade all affected AWS Wrappers to the patched versions provided by AWS: JDBC Wrapper to v2.6.5, Go Wrapper to 2025-10-17, NodeJS Wrapper to v2.0.1, Python Wrapper to v1.4.0, and PGSQL ODBC driver to v1.0.1. Additionally, review and restrict database user privileges to the minimum necessary, implement strict authentication and access controls to limit low-privilege user capabilities, and monitor database logs for unusual function creation or privilege escalation attempts. Employ network segmentation and firewall rules to restrict access to RDS instances. Regularly audit wrapper versions and configurations to ensure compliance with security best practices. Consider deploying runtime application self-protection (RASP) or database activity monitoring (DAM) tools to detect and block suspicious behavior related to function execution and privilege escalation.

Description

An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. We recommend customers upgrade to the following versions: AWS JDBC Wrapper to v2.6.5, AWS Go Wrapper to 2025-10-17, AWS NodeJS Wrapper to v2.0.1, AWS Python Wrapper to v1.4.0 and AWS PGSQL ODBC driver to v1.0.1

Reports on CVE-2025-12967

References

Community reviews

Loading reviews…