Skip to main content
VulnerabilityPublished

CVE-2025-14284: @tiptap/extension-link · Cross-site Scripting (XSS)

Affects @tiptap/extension-linkSource CVE Database V5

0

Public exploit available · CVSS 5.1 Medium : upgrade to 2.10.4 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.10.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade @tiptap/extension-link to 2.10.4.

Affected software

ProductAffectedFixed in
npm@tiptap/extension-linkpkg:npm/@tiptap/extension-linkOther threatsAffected
  • <2.10.4
Fixed in
  • 2.10.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade the @tiptap/extension-link package to version 2.10.4 or later, where the vulnerability is patched. Organizations should audit their codebases and dependencies to identify affected versions. Additionally, implement strict input validation to reject or sanitize any user-supplied URLs, especially those containing javascript: schemes or other executable content. Employ robust output encoding on all link attributes to prevent script execution. Use Content Security Policy (CSP) headers to restrict the execution of inline scripts and untrusted sources. Educate developers on secure coding practices related to user input handling in rich-text editors. Conduct thorough security testing of web applications incorporating this package, including penetration testing focused on XSS vectors. Monitor for suspicious user activity that could indicate exploitation attempts. Finally, maintain an up-to-date inventory of frontend dependencies to rapidly respond to newly disclosed vulnerabilities.

Description

Versions of the package @tiptap/extension-link before 2.10.4 are vulnerable to Cross-site Scripting (XSS) due to unsanitized user input allowed in setting or toggling links. An attacker can execute arbitrary JavaScript code in the context of the application by injecting a javascript: URL payload into these attributes, which is then triggered either by user interaction.

References

Community reviews

Loading reviews…