Skip to main content
VulnerabilityPublished Updated

CVE-2025-14865: Passster (WordPress plugin) · Cross-site Scripting

Affects Passster (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · fixed in 4.2.21 : update Passster (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.21
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
wpchillPassster – Password Protect Pages and ContentAffected
  • <=4.2.24
Fixed in–

AI-suggested

Since a partial patch was introduced in version 4.2.21 but the vulnerability persists through 4.2.24, users should monitor for an official full fix from the vendor. Until then, restrict Contributor-level access to trusted users only and consider disabling or removing the Passster plugin if feasible to reduce risk.

Description

The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.2.21.

References

Community reviews

Loading reviews…