CVE-2025-15675: Charitable (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Charitable (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.8.5.3 when convenient.
Data as of 1 Nov 2026, 08:20 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.5.3
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade Charitable (WordPress plugin) to 1.8.5.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Charitable | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict high-privilege campaign-management roles to trusted users only and consider additional input validation or sanitization controls at the application level if feasible.
Description
CVE-2025-15675 is a stored Cross-Site Scripting (XSS) vulnerability in the Charitable WordPress plugin versions before 1.8.5.3. It arises because one of the campaign image text fields is not properly sanitized or escaped before being output in an HTML attribute. This flaw allows users with a high-privilege campaign-management role to inject malicious scripts that execute on the front-end campaign page.