CVE-2025-21823: Linux kernel · batman-adv: Drop unmanaged ELP metric worker
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1146.156~18.04.1 : patch Linux kernel soon.
Data as of 6 Nov 2026, 15:09 UTC
- Patch
- Available – fixed in 5.4.0-1146.156~18.04.1, 5.4.0-1151.158~18.04.1, 5.4.0-1149.158~18.04.1 +83
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7510-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7512-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7517-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7518-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7521-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-4 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this vulnerability is available and included in Linux kernel versions 5.4.0-1146.156~18.04.1 and later, as well as other specified fixed versions. Users should apply the official kernel updates from their distribution vendors, such as the Ubuntu Security Notice USN-7510-1, and reboot systems to ensure the fix is active. No additional mitigation is required beyond applying these official patches.
Description
CVE-2025-21823 is a high-severity vulnerability in the Linux kernel's batman-adv module related to the handling of the ELP metric worker. The flaw involved unsafe management of per-neighbor metric worker tasks that could lead to invalid memory accesses and deadlocks during interface removal or module unload. The issue was resolved by redesigning the metric worker to handle all neighbors within the interface worker context, avoiding problematic locking and concurrency issues. Multiple Linux kernel versions prior to 5.4.0-1146.156~18.04.1 and specific 4.11.x and 4.13.x versions are affected. A patch is available and included in several fixed kernel releases.
References
- ubuntu.com/security/CVE-2025-21823 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-21823 (opens in a new tab)
- git.kernel.org/linus/8c8ecc98f5c65947b0070a24bac11e12e47cc65d (opens in a new tab)
- git.kernel.org/stable/c/0fdc3c166ac17b26014313fa2b93696354511b24 (opens in a new tab)
- git.kernel.org/stable/c/781a06fd265a8151f7601122d9c2e985663828ff (opens in a new tab)
- git.kernel.org/stable/c/8c8ecc98f5c65947b0070a24bac11e12e47cc65d (opens in a new tab)
- git.kernel.org/stable/c/a7aa2317285806640c844acd4cd2cd768e395264 (opens in a new tab)
- git.kernel.org/stable/c/af264c2a9adc37f4bdf88ca7f3affa15d8c7de9e (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7512-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7517-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7518-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7521-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-4 (opens in a new tab)