CVE-2025-21914: Linux kernel · slimbus: messaging: Free transaction ID in delayed interrupt scenario
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.4.0-1146.156~18.04.1 : patch Linux kernel soon.
Data as of 30 Oct 2026, 23:12 UTC
- Patch
- Available – fixed in 5.4.0-1146.156~18.04.1, 5.4.0-1151.158~18.04.1, 5.4.0-1149.158~18.04.1 +88
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7510-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7512-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7517-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7518-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-5 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-nvidiapkg:deb/ubuntu/linux-azure-nvidia?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this vulnerability is available and has been incorporated into multiple Linux kernel releases including versions 5.4.0-1146.156~18.04.1 and later. Users should apply the official Linux kernel updates provided by their distribution vendor, such as the Ubuntu Security Notice USN-7510-1, and reboot their systems to ensure the fix is active. No additional mitigation steps are required beyond applying the official patch.
Description
CVE-2025-21914 is a high-severity vulnerability in the Linux kernel's SLIMbus messaging subsystem. The flaw occurs when a delayed interrupt causes slim_do_transfer() to return a timeout error without freeing the transaction ID (TID). This leads to invalid memory access in the qcom_slim_ngd_rx_msgq_cb() function, potentially causing kernel panic and system instability. The issue has been fixed by ensuring the TID is freed before returning the timeout error. Multiple Linux kernel versions prior to 5.4.0-1146.156~18.04.1 and others are affected. A patch is available and included in several fixed kernel releases.
References
- ubuntu.com/security/CVE-2025-21914 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-21914 (opens in a new tab)
- git.kernel.org/linus/dcb0d43ba8eb9517e70b1a0e4b0ae0ab657a0e5a (opens in a new tab)
- git.kernel.org/stable/c/09d34c4cbc38485c7514069f25348e439555b282 (opens in a new tab)
- git.kernel.org/stable/c/0c541c8f6da23e0b92f0a6216d899659a7572074 (opens in a new tab)
- git.kernel.org/stable/c/18ae4cee05c310c299ba75d7477dcf34be67aa16 (opens in a new tab)
- git.kernel.org/stable/c/6abf3d8bb51cbaf886c3f08109a0462890b10db6 (opens in a new tab)
- git.kernel.org/stable/c/a32e5198a9134772eb03f7b72a7849094c55bda9 (opens in a new tab)
- git.kernel.org/stable/c/cec8c0ac173fe5321f03fdb1a09a9cb69bc9a9fe (opens in a new tab)
- git.kernel.org/stable/c/dcb0d43ba8eb9517e70b1a0e4b0ae0ab657a0e5a (opens in a new tab)
- git.kernel.org/stable/c/faac8e894014e8167471a8e4a5eb35a8fefbb82a (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7510-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7511-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7512-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7516-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7517-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7518-1 (opens in a new tab)