CVE-2025-2225: Responsive Addons for Elementor (WordPress plugin) · Cross-site Scripting
Affects Responsive Addons for Elementor (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.4 Medium · fixed in 1.6.9 : update Responsive Addons for Elementor (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| cyberchimps Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates | Affected
| Fixed in– |
AI-suggested
The vulnerability was partially patched in version 1.6.9, so upgrading to this version is recommended as a temporary measure. Monitor the vendor's official channels for a complete fix. Until a full patch is available, restrict Contributor-level access to trusted users only and consider additional input validation or web application firewall rules to detect and block malicious payloads targeting the 'rael_title_tag' parameter.
Description
The Responsive Addons for Elementor – Free Elementor Addons Plugin and Elementor Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘rael_title_tag' parameter in all versions up to, and including, 1.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 1.6.9.
References
- wordfence.com/threat-intel/vulnerabilities/id/f5ace7fb-530e-4a69-bbf7-e2c66491dd75?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/responsive-addons-for-elementor/trunk/includes/widgets-manager/widgets/class-responsive-addons-for-elementor-icon-box.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3261241/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3263280/ (opens in a new tab)