CVE-2025-22676: AWS S3 for WordPress Plugin – Upcasted · Cross-site Scripting
Affects AWS S3 for WordPress Plugin – UpcastedSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium · patch available : update AWS S3 for WordPress Plugin – Upcasted when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 16 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| upcasted AWS S3 for WordPress Plugin – Upcasted | Affected
| Fixed in– |
AI-suggested
A patch is available for this vulnerability, and since the product is a cloud service, the vendor manages remediation server-side. Users should verify with the vendor advisory that the patch has been applied. No additional action is required if the vendor confirms mitigation. If using a self-hosted or on-premises version, update to the fixed version beyond 3.0.3 as soon as possible.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in upcasted AWS S3 for WordPress Plugin – Upcasted upcasted-s3-offload allows Stored XSS.This issue affects AWS S3 for WordPress Plugin – Upcasted: from n/a through <= 3.0.3.