Skip to main content
CVE-2025-27407VulnerabilityPublished Updated

CVE-2025-27407: rmosolgo graphql-ruby · Code Injection

Affects rmosolgo graphql-rubySource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical · fixed in 2.3.21 : patch rmosolgo graphql-ruby as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
3.1% chance of exploitation in 30 days – higher than 87% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.21, 2.2.17, 2.1.14 +4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
RubyGemsgraphql-rubypkg:gem/graphql-rubyOther threatsAffected
  • <1.11.8
  • <1.12.25
  • <1.13.24
  • <2.0.32
  • <2.1.14
  • <2.2.17
  • <2.3.21
Fixed in
  • 1.11.8
  • 1.12.25
  • 1.13.24
  • 2.0.32
  • 2.1.14
  • 2.2.17
  • 2.3.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade graphql-ruby to one of the patched versions: 1.11.8 or later, 1.12.25 or later, 1.13.24 or later, 2.0.32 or later, 2.1.14 or later, 2.2.17 or later, or 2.3.21 or later. 2. Avoid loading GraphQL schemas from untrusted or unauthenticated sources. Validate and sanitize any external schema definitions before loading. 3. Implement strict access controls and network segmentation to limit exposure of services that perform schema loading. 4. Monitor application logs and network traffic for unusual schema loading activities or unexpected introspection queries. 5. Employ runtime application self-protection (RASP) or endpoint detection and response (EDR) tools to detect anomalous code execution. 6. Conduct code reviews and security testing focusing on GraphQL schema handling and introspection features. 7. Educate development teams about the risks of dynamic code generation and the importance of secure schema management. 8. If immediate upgrade is not possible, consider disabling schema loading from introspection or applying custom validation layers as temporary mitigations.

Description

graphql-ruby is a Ruby implementation of GraphQL. Starting in version 1.11.5 and prior to versions 1.11.8, 1.12.25, 1.13.24, 2.0.32, 2.1.14, 2.2.17, and 2.3.21, loading a malicious schema definition in `GraphQL::Schema.from_introspection` (or `GraphQL::Schema::Loader.load`) can result in remote code execution. Any system which loads a schema by JSON from an untrusted source is vulnerable, including those that use GraphQL::Client to load external schemas via GraphQL introspection. Versions 1.11.8, 1.12.25, 1.13.24, 2.0.32, 2.1.14, 2.2.17, and 2.3.21 contain a patch for the issue.

References

Community reviews

Loading reviews…