Skip to main content
CVE-2025-2809VulnerabilityPublished Updated

CVE-2025-2809: azurecurve Shortcodes in Comments (WordPress plugin) · Code Injection

Affects azurecurve Shortcodes in Comments (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.3 High · patch available : patch azurecurve Shortcodes in Comments (WordPress plugin) soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
azurecurve azurecurve Shortcodes in CommentsAffected
  • =0
Fixed in–

AI-suggested

A patch is available for this vulnerability. Users of the azurecurve Shortcodes in Comments plugin should update to the latest version beyond 2.0.2 to remediate the issue. No additional vendor advisory details are provided, so check the official plugin repository or vendor site for the patch and update instructions.

Description

The azurecurve Shortcodes in Comments plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.0.2. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.

References

Community reviews

Loading reviews…