Skip to main content
VulnerabilityPublished Updated

CVE-2025-31699: Apache Traffic Server · HTTP Request Smuggling

Affects Apache Traffic ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.9 High.

Data as of 29 Oct 2026, 18:50 UTC

CVSS 3.1 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 3.18.9
CNA (apache)CVSS 4.09.1
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Traffic ServerAffected
  • >=8.0.0 <=8.1.11
  • >=9.0.0 <=9.2.15
  • >=10.0.0 <=10.1.4
  • =10.2.0
Fixed in–

AI-suggested

Users should upgrade Apache Traffic Server to versions 9.2.16, 10.1.5, or 10.2.1, which contain fixes for this vulnerability. No other mitigations are specified by the vendor advisory.

Description

CVE-2025-31699 is a high-severity HTTP request/response smuggling vulnerability in Apache Traffic Server. It occurs when the server returns an origin connection to the shared pool while the origin is still waiting on a request body that the client declared but never fully sent, including cases using Expect: 100-continue. This allows the origin to misinterpret subsequent requests as leftover body data, enabling attackers to smuggle requests past access controls, disrupt other users' requests, or poison the cache. The issue affects multiple versions from 8.0.0 through 8.1.11, 9.0.0 through 9.2.15, 10.0.0 through 10.1.4, and version 10.2.0. Fixed versions are 9.2.16, 10.1.5, and 10.2.1.

References

Community reviews

Loading reviews…