CVE-2026-111816: Apache Traffic Server · HTTP Request Smuggling
Affects Apache Traffic ServerSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical · fixed in 9.2.16 : patch Apache Traffic Server as a priority.
Data as of 29 Oct 2026, 18:50 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 3.1 | 9.3 |
|---|---|---|
| CNA (apache) | CVSS 4.0 | 9.2 |
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.2.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Traffic Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache Traffic Server to versions 9.2.16, 10.1.5, or 10.2.1, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
CVE-2026-111816 is a critical HTTP request/response smuggling vulnerability in Apache Traffic Server. The issue arises from the server forwarding a malformed 302 response that should have been rejected due to a parsing error. However, a Transfer-Encoding: chunked carve-out bypassed the rejection path, causing the server to store and serve a response that peers interpret differently. This discrepancy allows cache poisoning and response-framing desynchronization attacks. The vulnerability affects Apache Traffic Server versions from 8.0.0 through 8.1.11, 9.0.0 through 9.2.15, 10.0.0 through 10.1.4, and version 10.2.0. Fixed versions are 9.2.16, 10.1.5, and 10.2.1.