Skip to main content
VulnerabilityPublished Updated

CVE-2025-32696: Wikimedia Foundation MediaWiki · Improper Preservation of Permissions

Affects Wikimedia Foundation MediaWikiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 0.0 Medium · fixed in 1.43.1 : update Wikimedia Foundation MediaWiki when convenient.

Data as of 30 Oct 2026, 00:15 UTC

CVSS 4.0 base score
0.0Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (wikimedia-foundation)CVSS 4.00.0
Patch
Available – fixed in 1.43.1, 1.42.6, 1.39.12
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/RE:M/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Wikimedia Foundation MediaWiki to 1.43.1, 1.42.6 or 1.39.12.

Affected software

ProductAffectedFixed in
Wikimedia Foundation MediaWikiAffected
  • <1.39.12
  • >=1.39.12 <1.42.6
  • >=1.42.6 <1.43.1
Fixed in
  • 1.39.12
  • 1.42.6
  • 1.43.1

AI-suggested

Since the vulnerability affects versions before 1.39.12, 1.42.6, and 1.43.1, upgrading MediaWiki to these or later versions is recommended to remediate the issue. No vendor advisory or patch links were provided, so confirm patch availability from official Wikimedia Foundation sources before applying updates.

Description

CVE-2025-32696 is an Improper Preservation of Permissions vulnerability in Wikimedia Foundation's MediaWiki software. It affects specific program files related to revert actions and API file revert functionality. The issue impacts MediaWiki versions before 1.39.12, 1.42.6, and 1.43.1. The vulnerability was published on April 10, 2025. No public exploits or active exploitation are known at this time.

References

Community reviews

Loading reviews…