CVE-2025-37801: Linux kernel · spi: spi-imx: Add check for spi_imx_setupxfer()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-1046.49~22.04.1 : patch Linux kernel soon.
Data as of 30 Oct 2026, 22:50 UTC
- Patch
- Available – fixed in 6.8.0-1046.49~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1046.53~22.04.1 +29
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-7594-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-3 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to Linux kernel versions 6.8.0 or later as listed in the fixed versions. The vendor advisory from Ubuntu confirms that this issue is resolved in these releases. Users should update their systems to these fixed kernel versions to mitigate the vulnerability.
Description
A NULL pointer dereference vulnerability in the Linux kernel's spi-imx driver was fixed by adding a check for the return value of spi_imx_setupxfer(). Without this check, spi_imx->rx and spi_imx->tx function pointers could be NULL, leading to a kernel crash. This issue affects multiple Linux kernel versions prior to 6.8.0 and specific older versions. The vulnerability has a high severity score and was addressed in several patched kernel releases.
References
- ubuntu.com/security/CVE-2025-37801 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-37801 (opens in a new tab)
- git.kernel.org/linus/951a04ab3a2db4029debfa48d380ef834b93207e (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7594-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8031-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8052-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-7 (opens in a new tab)
- ubuntu.com/security/notices/USN-8028-8 (opens in a new tab)
- ubuntu.com/security/notices/USN-8052-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8074-1 (opens in a new tab)