Skip to main content
VulnerabilityPublished Updated

CVE-2025-38000: Linux kernel · sch_hfsc: Fix qlen accounting bug when using peek in hfsc_enqueue()

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-38000· High

Not known to be exploited · CVSS 7.8 High · fixed in 4.15.0-1190.205~14.04.1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:39 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.15.0-1190.205~14.04.1, 4.15.0-1182.195~16.04.1, 4.15.0-1190.205~16.04.1 +106
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-63.66
Fixed in
  • 6.8.0-63.66
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1031.33
Fixed in
  • 6.8.0-1031.33
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1009.9~24.04.1
Fixed in
  • 6.14.0-1009.9~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1031.36
Fixed in
  • 6.8.0-1031.36
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • <6.11.0-1018.18~24.04.1
Fixed in
  • 6.11.0-1018.18~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vulnerability is fixed in Linux kernel versions 4.15.0-1190.205~14.04.1, 4.15.0-1182.195~16.04.1, 4.15.0-1190.205~16.04.1, 4.15.0-1175.192~16.04.1, 4.15.0-239.251~16.04.1, 4.15.0-1144.155~16.04.1, 4.15.0-239.251, 4.15.0-1182.195, 5.4.0-1148.158~18.04.1, and 4.15.0-1190.205. Users should update to these or later versions and reboot the system to apply the fixes. According to the Ubuntu advisory, recompilation and reinstallation of third-party kernel modules may be required due to ABI changes.

Description

CVE-2025-38000 is a high-severity vulnerability in the Linux kernel's HFSC traffic control subsystem. The flaw involves incorrect queue length accounting when enqueuing the first packet to an HFSC class, which can lead to inconsistent queue state and potential use-after-free conditions. This issue has been fixed by adjusting the order of queue length increments to ensure accurate accounting during packet enqueue operations.

References

Community reviews

Loading reviews…