Skip to main content
VulnerabilityPublished Updated

CVE-2025-38499: Linux kernel · clone_private_mnt(): make sure that caller has CAP_SYS_ADMIN in the right userns

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1097.104~20.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:27 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1097.104~20.04.1, 5.15.0-1102.111~20.04.1, 5.15.0-1097.106~20.04.1 +64
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-100.100
Fixed in
  • 6.8.0-100.100
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.49
Fixed in
  • 6.8.0-1046.49
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1013.13~24.04.1
Fixed in
  • 6.14.0-1013.13~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.52
Fixed in
  • 6.8.0-1046.52
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The vulnerability is fixed in Linux kernel versions 5.15.0-1097.104~20.04.1, 5.15.0-1102.111~20.04.1, 5.15.0-1097.106~20.04.1, 5.15.0-163.173~20.04.1, 5.15.0-1091.94~20.04.1, and related fixed versions listed in the advisory. Users should upgrade to these fixed kernel versions as provided by their Linux distribution. No additional mitigations are indicated by the vendor advisory.

Description

CVE-2025-38499 is a high-severity vulnerability in the Linux kernel affecting the clone_private_mnt() function. The flaw involves insufficient verification that the caller has CAP_SYS_ADMIN capability in the correct user namespace when performing certain mount operations. This could allow exposure of hidden mounts that should not be accessible or undoable by the caller. The issue was addressed by adding proper capability checks to prevent unauthorized mount namespace cloning.

References

Community reviews

Loading reviews…