CVE-2025-39986: Linux kernel · can: sun4i_can: populate ndo_change_mtu() to prevent buffer overflow
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1100.107~20.04.2 : patch Linux kernel soon.
Data as of 28 Oct 2026, 11:20 UTC
- Patch
- Available – fixed in 5.15.0-1100.107~20.04.2, 5.15.0-1110.119~20.04.1, 5.15.0-1100.109~20.04.1 +68
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8033-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8034-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8034-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-7 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-8 (opens in a new tab)
- ubuntu.com/security/notices/USN-8095-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8100-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and fixed versions include Linux kernel releases 5.15.0-1094.97~20.04.1 and later. Users should update to these fixed kernel versions or later to remediate the vulnerability. The fix involves populating the ndo_change_mtu() callback to enforce valid MTU limits, preventing exploitation. No additional mitigations are required once updated.
Description
CVE-2025-39986 is a vulnerability in the Linux kernel's sun4i_can driver where the lack of proper MTU validation allows an attacker to configure an invalid MTU and inject malicious CAN XL frames via PF_PACKET sockets. This leads to a buffer overflow in the driver due to misinterpretation of frame length fields. The issue is fixed by populating the ndo_change_mtu() operation to enforce MTU limits.
References
- ubuntu.com/security/CVE-2025-39986 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-39986 (opens in a new tab)
- git.kernel.org/linus/61da0bd4102c459823fbe6b8b43b01fb6ace4a22 (opens in a new tab)
- git.kernel.org/stable/c/063539db42203b29d5aa2adf0cae3d68c646a6b6 (opens in a new tab)
- git.kernel.org/stable/c/2e423e1990f3972cbea779883fef52c2f2acb858 (opens in a new tab)
- git.kernel.org/stable/c/4f382cc887adca8478b9d3e6b81aa6698a95fff4 (opens in a new tab)
- git.kernel.org/stable/c/60463a1c138900494cb3adae41142a11cd8feb3c (opens in a new tab)
- git.kernel.org/stable/c/61da0bd4102c459823fbe6b8b43b01fb6ace4a22 (opens in a new tab)
- git.kernel.org/stable/c/7f7b21026a6febdb749f6f6f950427245aa86cce (opens in a new tab)
- git.kernel.org/stable/c/a61ff7ac93270d20ca426c027d6d01c8ac8e904c (opens in a new tab)
- git.kernel.org/stable/c/de77841652e57afbc46e9e1dbf51ee364fc008e1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8034-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8034-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8033-7 (opens in a new tab)