Skip to main content
VulnerabilityPublished Updated

CVE-2025-40027: Linux kernel · net/9p: fix double req put in p9_fd_cancelled

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1100.107~20.04.2 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:19 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1100.107~20.04.2, 5.15.0-1110.119~20.04.1, 5.15.0-1100.109~20.04.1 +68
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-7.7
Fixed in
  • 6.17.0-7.7
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1004.4
Fixed in
  • 6.17.0-1004.4
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1006.6
Fixed in
  • 6.17.0-1006.6
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1004.4
Fixed in
  • 6.17.0-1004.4
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1005.5
Fixed in
  • 6.17.0-1005.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in multiple updated Linux kernel versions as listed in the established facts and Ubuntu security notices USN-7906-1 and USN-7906-2. Users should apply these kernel updates and reboot their systems to ensure the vulnerability is remediated. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. No additional mitigation steps are indicated beyond applying the official patches.

Description

CVE-2025-40027 is a concurrency vulnerability in the Linux kernel's 9p filesystem client. It involves a race condition causing a double removal of a request from a list, leading to a potential use-after-free or memory corruption. The flaw was identified by Syzkaller and fixed by updating the status check in the p9_fd_cancelled function to prevent double deletion. This vulnerability affects multiple Linux kernel versions and has been addressed in several patched releases.

References

Community reviews

Loading reviews…