Skip to main content
CVE-2025-42620VulnerabilityPublished

CVE-2025-42620: CIRCL Vulnerability-Lookup · XSS or 'Cross-site Scripting'

Affects CIRCL Vulnerability-LookupSource CVE Database V5

0

Not known to be exploited · CVSS 8.3 High : upgrade to 2.18.0 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.18.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade CIRCL Vulnerability-Lookup to 2.18.0.

Affected software

ProductAffectedFixed in
CIRCL Vulnerability-LookupAffected
  • =0
  • <2.18.0
Fixed in
  • 2.18.0

AI-suggested

European organizations should immediately upgrade Vulnerability-Lookup to version 2.18.0 or later where the vulnerability is patched. In addition, implement strict input validation and sanitization on all user-controlled fields, especially those rendered as HTML, to prevent injection of malicious scripts. Replace unsafe DOM injection methods such as innerHTML with safer alternatives like textContent or use well-maintained libraries that sanitize Markdown to HTML securely. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS payloads. Conduct regular code audits and penetration testing focused on input handling and frontend rendering logic. Limit permissions to create or edit comments and bundles to trusted users and monitor for unusual activity. Educate users about the risks of interacting with untrusted content within the platform. Finally, maintain up-to-date incident response plans to quickly address any exploitation attempts.

Description

In affected versions, vulnerability-lookup handled user-controlled content in comments and bundles in an unsafe way, which could lead to stored Cross-Site Scripting (XSS). On the backend, the related_vulnerabilities field of bundles accepted arbitrary strings without format validation or proper sanitization. On the frontend, comment and bundle descriptions were converted from Markdown to HTML and then injected directly into the DOM using string templates and innerHTML. This combination allowed an attacker who could create or edit comments or bundles to store crafted HTML/JavaScript payloads which would later be rendered and executed in the browser of any user visiting the affected profile page (user.html). This issue affects Vulnerability-Lookup: before 2.18.0.

References

Community reviews

Loading reviews…