CVE-2025-48866: ModSecurity · Excessive Platform Resource Consumption within a Loop
Affects ModSecuritySource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 2.9.10 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.9.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade owasp-modsecurity/ModSecurity to 2.9.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubowasp-modsecurity/ModSecuritypkg:github/owasp-modsecurity/ModSecurityOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading ModSecurity to version 2.9.10 or later, where this vulnerability is fixed. If immediate upgrading is not feasible, administrators should audit their ModSecurity rulesets to identify and disable any rules that use the `sanitiseArg` or `sanitizeArg` actions, as these are the vectors triggering the excessive resource consumption. Monitoring WAF logs for unusual spikes in argument processing or resource usage can help detect attempted exploitation. Implementing rate limiting and web server resource controls can also help mitigate the impact of potential DoS attempts. Organizations should ensure their incident response and business continuity plans account for potential WAF outages. Finally, maintaining an up-to-date inventory of ModSecurity deployments and versions across the infrastructure will facilitate timely patch management and vulnerability remediation.
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions prior to 2.9.10 contain a denial of service vulnerability similar to GHSA-859r-vvv8-rm8r/CVE-2025-47947. The `sanitiseArg` (and `sanitizeArg` - this is the same action but an alias) is vulnerable to adding an excessive number of arguments, thereby leading to denial of service. Version 2.9.10 fixes the issue. As a workaround, avoid using rules that contain the `sanitiseArg` (or `sanitizeArg`) action.
References
- github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-f82j-8pp7-cw2w (opens in a new tab)
- github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-859r-vvv8-rm8r (opens in a new tab)
- github.com/owasp-modsecurity/ModSecurity/commit/3a54ccea62d3f7151bb08cb78d60c5e90b53ca2e (opens in a new tab)
- github.com/owasp-modsecurity/ModSecurity/wiki/Reference-Manual-(v2.x) (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/06/msg00009.html (opens in a new tab)