CVE-2025-49812: Apache HTTP Server · Improper Authentication
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 7.4 High · fixed in 2.4.64 : patch Apache HTTP Server soon.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache HTTP Server | Affected
| Fixed in– |
AI-suggested
The primary mitigation is to upgrade Apache HTTP Server to version 2.4.64 or later, which removes support for TLS upgrades and eliminates the vulnerable code path. Organizations should audit their Apache configurations to identify and disable any use of 'SSLEngine optional' that enables TLS upgrades. Where upgrading immediately is not feasible, disabling TLS upgrades and enforcing strict HTTPS connections without fallback to HTTP is recommended. Network-level mitigations include deploying TLS interception detection, enforcing HTTP Strict Transport Security (HSTS), and monitoring for unusual session behaviors indicative of desynchronization attacks. Additionally, organizations should ensure that their network infrastructure prevents man-in-the-middle positioning by using secure network segments, VPNs, and encrypted internal communications. Regular security assessments and penetration testing should include checks for HTTP desynchronization vulnerabilities. Finally, educating system administrators about the risks of optional TLS upgrades and proper SSL/TLS configuration best practices will help prevent similar issues.
Description
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
References
- httpd.apache.org/security/vulnerabilities_24.html (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/08/msg00009.html (opens in a new tab)
- openwall.com/lists/oss-security/2025/07/09/3 (opens in a new tab)
- openwall.com/lists/oss-security/2025/07/10/2 (opens in a new tab)
- openwall.com/lists/oss-security/2025/07/10/9 (opens in a new tab)