Skip to main content
VulnerabilityPublished

CVE-2025-51991: XWiki · Code Injection

Source CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · CVSS 8.8 High · fixed in 17.3.1 : patch affected systems soon.

Data as of 26 Oct 2026, 16:39 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
3.6% chance of exploitation in 30 days – higher than 89% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2025

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

European organizations should immediately review and restrict administrator access to XWiki instances, enforcing strong authentication mechanisms such as multi-factor authentication (MFA). Administrators should be trained to recognize phishing and social engineering attempts to protect credentials. It is critical to monitor and audit administrative actions within XWiki to detect suspicious behavior. As a temporary mitigation, administrators can avoid modifying the HTTP Meta Info field or disable the Global Preferences Presentation section if feasible. Implementing web application firewalls (WAFs) with custom rules to detect and block suspicious Velocity template syntax in HTTP requests may provide additional protection. Regular backups and incident response plans should be updated to prepare for potential exploitation scenarios.

Description

XWiki through version 17.3.0 is vulnerable to Server-Side Template Injection (SSTI) in the Administration interface, specifically within the HTTP Meta Info field of the Global Preferences Presentation section. An authenticated administrator can inject crafted Apache Velocity template code, which is rendered on the server side without proper validation or sandboxing. This enables the execution of arbitrary template logic, which may expose internal server information or, in specific configurations, lead to further exploitation such as remote code execution or sensitive data leakage. The vulnerability resides in improper handling of dynamic template rendering within user-supplied configuration fields.

References

Community reviews

Loading reviews…