Skip to main content
CVE-2025-53484VulnerabilityPublished Updated

CVE-2025-53484: Wikimedia Foundation Mediawiki – SecurePoll extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – SecurePoll extensionSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 1.44.0 : patch Wikimedia Foundation Mediawiki – SecurePoll extension as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.0, 1.40.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Wikimedia Foundation Mediawiki – SecurePoll extension to 1.44.0, 1.43.0 or 1.40.0.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - SecurePoll extensionAffected
  • >=1.39.0 <1.40.0
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0

AI-suggested

European organizations should prioritize upgrading the SecurePoll extension to the fixed versions: 1.39.13 or later for the 1.39.x branch, 1.42.7 or later for the 1.42.x branch, and 1.43.2 or later for the 1.43.x branch. If you cannot patch yet, organizations should implement strict input validation and output encoding on all user-supplied data related to polls and page names within their Mediawiki deployments. Employing Content Security Policy (CSP) headers can help mitigate the impact of injected scripts by restricting script execution sources. Additionally, organizations should audit their Mediawiki configurations to disable or limit the use of the SecurePoll extension if not essential. Monitoring web server logs and Mediawiki access logs for unusual requests or payloads targeting poll options or page names can help detect attempted exploitation. User awareness training should emphasize caution when interacting with wiki content, especially in environments where the extension is used. Finally, organizations should maintain regular backups of wiki content to enable recovery in case of defacement or data manipulation.

Description

User-controlled inputs are improperly escaped in: * VotePage.php (poll option input) * ResultPage::getPagesTab() and getErrorsTab() (user-controllable page names) This allows attackers to inject JavaScript and compromise user sessions under certain conditions. This issue affects Mediawiki - SecurePoll extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…