Skip to main content
VulnerabilityPublished

CVE-2025-58136: Apache Traffic Server · Always-Incorrect Control Flow Implementation

Affects Apache Traffic ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Traffic ServerAffected
  • >=10.0.0 <=10.1.1
  • >=9.0.0 <=9.2.12
Fixed in–

AI-suggested

Upgrade Apache Traffic Server to version 9.2.13 or 10.1.2, which contain official fixes for this vulnerability. For systems that cannot immediately upgrade, ensure the configuration setting proxy.config.http.request_buffer_enabled is set to 0 (the default) to mitigate the issue. No other mitigations are indicated by the vendor.

Description

CVE-2025-58136 is a high-severity vulnerability in Apache Traffic Server versions 9.0.0 through 9.2.12 and 10.0.0 through 10.1.1. It involves a bug in the handling of POST requests that can cause the server to crash under certain conditions.

References

Community reviews

Loading reviews…