Skip to main content
CVE-2025-59471VulnerabilityPublished

CVE-2025-59471: vercel next · Vulnerability

Affects vercel nextSource CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium · fixed in 16.1.5 : update vercel next when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.1.5, 15.5.10, 14.0 +4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
vercelnextAffected
  • >=10.0 <10.0
  • >=11.0 <11.0
  • >=12.0 <12.0
  • >=13.0 <13.0
  • >=14.0 <14.0
  • >=15.0 <15.5.10
  • >=16.0 <16.1.5
Fixed in
  • 16.1.5
  • 15.5.10
  • 14.0
  • 13.0
  • 12.0
  • 11.0
  • 10.0
GitHubvercel/next.jspkg:github/vercel/next.jsOther threatsAffected
  • =10.0
  • =11.0
  • =12.0
  • =13.0
  • =14.0
  • =15.0
  • =16.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade Next.js to version 15.5.10 or 16.1.5 or later, which include fixes to enforce maximum image size limits and prevent memory exhaustion. 2. Review and restrict the remotePatterns configuration to only trusted and necessary external domains to minimize exposure. 3. Implement network-level protections such as rate limiting and request size limits on the image optimization endpoint to reduce the risk of abuse. 4. Monitor application logs and resource usage for unusual spikes in memory consumption or image optimization requests. 5. Consider deploying Web Application Firewalls (WAFs) with custom rules to detect and block requests for unusually large images or suspicious patterns targeting the image optimizer endpoint. 6. Educate development and operations teams about the risks of overly permissive remotePatterns configurations and enforce secure coding and deployment practices.

Description

CVE-2025-59471 is a denial of service vulnerability affecting self-hosted Next.js applications using the Image Optimizer with remotePatterns configured for external domains. The vulnerability arises because the image optimization endpoint loads external images fully into memory without size limits, allowing attackers to cause out-of-memory conditions by requesting large images. Exploitation requires that remotePatterns allow external domains and that attackers control or serve large images from these domains. The vulnerability affects Next.js versions 10.0 through 16.0. No authentication or user interaction is needed, but the attack complexity is high due to the need to control large images on allowed domains. The CVSS score is 5.

References

Community reviews

Loading reviews…