CVE-2025-60753: libarchive · CVE-2025-60753 is a medium severity
Affects libarchiveSource CVE Database V5
Not known to be exploited · CVSS 5.5 Medium : upgrade to 3.8.1 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.8.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade libarchive/libarchive to 3.8.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublibarchive/libarchivepkg:github/libarchive/libarchiveOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2025-60753, European organizations should promptly upgrade libarchive to version 3.8.1 or later, where the vulnerability has been addressed. If you cannot patch yet, restrict the use of bsdtar for processing archives from untrusted sources, especially those employing -s substitution rules. Implement strict input validation and sandboxing for archive extraction processes to limit resource consumption and isolate potential crashes. Monitoring system memory usage during extraction tasks can help detect abnormal behavior early. Additionally, review and harden user permissions to prevent unauthorized local access that could trigger exploitation. For automated workflows, consider alternative extraction tools that are not affected by this vulnerability or disable substitution rule processing if not required. Regularly audit and update third-party libraries to maintain security hygiene.
Description
CVE-2025-60753 is a medium severity vulnerability in libarchive's bsdtar utility prior to version 3.8.1. It arises from improper handling of crafted -s substitution rules in the apply_substitution function, leading to unbounded memory allocation. This flaw can cause an Out-of-Memory (OOM) crash, resulting in a denial of service. Exploitation requires local access and user interaction, with no impact on confidentiality or integrity. No known exploits are currently in the wild. European organizations using vulnerable versions of bsdtar, especially in environments processing untrusted tar archives, may face service disruptions. Mitigation involves updating to libarchive 3.8.