Skip to main content
CVE-2025-61646VulnerabilityPublished Updated

CVE-2025-61646: Wikimedia Foundation MediaWiki · Path Traversal

Affects Wikimedia Foundation MediaWikiSource CVE Database V5

0

Not known to be exploited · CVSS 1.2 Low : upgrade to 1.39.14 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 4.0 base score
1.2Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.39.14, 1.44.1, 1.43.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade MediaWiki to 1.39.14; mediawiki/mediawiki to 1.44.1, 1.43.4 or 1.39.14.

Affected software

ProductAffectedFixed in
Wikimedia FoundationMediaWikiAffected
  • < 1.39.14, 1.43.4, 1.44.1
Fixed in
  • 1.39.14
Packagistmediawiki/mediawikipkg:composer/mediawiki/mediawikiOther threatsAffected
  • <1.39.14
  • <1.43.4
  • <1.44.1
Fixed in
  • 1.39.14
  • 1.43.4
  • 1.44.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, administrators should implement strict input validation and sanitization on any user-supplied file path parameters, especially in the EnhancedChangesList.php component. Restricting web server file system permissions to limit access to sensitive files can reduce the impact of potential exploitation. Monitoring web server logs for suspicious requests targeting the RecentChanges functionality can help detect attempted exploitation. Employing web application firewalls (WAFs) with rules to block directory traversal patterns may provide temporary protection. Additionally, educating users about the risk of interacting with untrusted links or content can reduce the likelihood of successful exploitation requiring user interaction. Regular security audits and vulnerability scanning of MediaWiki deployments are recommended to detect and remediate similar issues proactively.

Description

Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/RecentChanges/EnhancedChangesList.Php. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1.

References

Community reviews

Loading reviews…