CVE-2025-61653: Wikimedia Foundation TextExtracts · Path Traversal
Affects Wikimedia Foundation TextExtractsSource CVE Database V5
Not known to be exploited · CVSS 2.7 Low : upgrade to 1.39.14 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.39.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Wikimedia Foundation TextExtracts to 1.39.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wikimedia FoundationTextExtracts | Affected
| Fixed in
|
AI-suggested
Organizations should first identify if they are running affected versions of the Wikimedia Foundation TextExtracts extension. In the interim, restricting external access to the API endpoints that utilize TextExtracts can reduce exposure. Implementing web application firewalls (WAFs) with rules to detect and block directory traversal attempts targeting ApiQueryExtracts.php is advisable. Additionally, auditing MediaWiki configurations to limit API access to trusted users or networks can mitigate risk. Regularly reviewing server logs for suspicious file path requests and employing intrusion detection systems to alert on anomalous API usage will help detect exploitation attempts early.
Description
Vulnerability in Wikimedia Foundation TextExtracts. This vulnerability is associated with program files includes/ApiQueryExtracts.Php. This issue affects TextExtracts: from * before 1.39.14, 1.43.4, 1.44.1.