CVE-2025-62184: Pegasystems Pega Infinity · Cross-site Scripting
Affects Pegasystems Pega InfinitySource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to Infinity 25.1.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in Infinity 25.1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade Pegasystems Pega Infinity to Infinity 25.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PegasystemsPega Infinity | Affected
| Fixed in
|
Mavencom.pega/pega-infinitypkg:maven/com.pega/pega-infinityOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2025-62184, organizations should first verify if they are running affected versions of Pega Infinity (8.1.0 through 25.1.0) and restrict administrative access to trusted personnel only. Implement strict input validation and output encoding on all user-supplied data within the administrative UI components to prevent script injection. Employ Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in the browser context. Monitor administrative accounts for unusual activity and enforce multi-factor authentication to reduce the risk of compromised credentials. Regularly review and update access controls to minimize the number of users with administrative privileges. Stay in contact with Pegasystems for official patches or security advisories addressing this vulnerability and apply updates promptly once available. Additionally, conduct security awareness training for administrators to recognize phishing or social engineering attempts that could lead to account compromise. Consider deploying web application firewalls (WAFs) with custom rules to detect and block XSS payloads targeting the Pega Infinity interface.
Description
Pega Platform versions 8.1.0 through 25.1.0 are affected by a Stored Cross-site Scripting vulnerability in a user interface component. Requires an administrative user and given extensive access rights, impact to Confidentiality is low and Integrity is none.