Skip to main content
VulnerabilityPublished

CVE-2025-64187: OctoPrint · Basic XSS

Affects OctoPrintSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.6 Medium : upgrade to 1.11.4 when convenient.

Data as of 4 Nov 2026, 18:47 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.04.6
Patch
Available – fixed in 1.11.4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade OctoPrint to 1.11.4.

Affected software

ProductAffectedFixed in
OctoPrint OctoPrintAffected
  • <1.11.4
Fixed in
  • 1.11.4

AI-suggested

Upgrade OctoPrint to version 1.11.4 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

OctoPrint versions 1.11.3 and earlier contain a vulnerability that allows injection of arbitrary HTML and JavaScript into Action Command notifications and popup prompts. This can be exploited by convincing a user to print a specially crafted file, potentially disrupting prints or performing actions within the OctoPrint instance. The issue is fixed in version 1.11.4.

References

Community reviews

Loading reviews…