CVE-2025-55672: Apache Superset's chart visualization has a stored Cross-Site Scripting (XSS) vulnerability
Affects apache-supersetSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 5.0.0 when convenient.
Data as of 4 Nov 2026, 18:16 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 5.3 |
|---|
- Patch
- Available – fixed in 5.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade apache-superset to 5.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIapache-superset | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Superset to version 5.0.0 or later, where this vulnerability is fixed. No other mitigations are specified or required.
Description
Apache Superset versions before 5.0.0 contain a stored Cross-Site Scripting (XSS) vulnerability in the chart visualization feature. Authenticated users with chart editing permissions can inject malicious scripts into column labels, which execute in other users' browsers when they hover over the chart. This can lead to session hijacking or arbitrary command execution. The issue is fixed in version 5.0.0.