Apache Superset data query improperly discloses database schema information to low-privileged guest user
Affects apache-supersetSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.1.3.post1 when convenient.
Data as of 4 Nov 2026, 18:16 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 5.3 |
|---|
- Patch
- Available – fixed in 4.1.3.post1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade apache-superset to 4.1.3.post1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIapache-superset | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Superset to version 4.1.3.post1 or later, where this issue is fixed. Applying this official patch fully mitigates the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
Apache Superset versions before 4.1.3 improperly disclose database schema information to low-privileged guest users. Specifically, when a guest user accesses a chart, the API response from the /chart/data endpoint includes a query field that reveals underlying query details such as table names. This information disclosure vulnerability is fixed in version 4.1.3.post1.